Welcome Guest  |  Login  |  Forum Registration

Sl1 as soundcard-interface asio problem


Brandat 1:17:56 - 20 March 2017

Software Being Used
Scratch live 2.5, cubase 8 x64

Software Version

Operating System
Windows 10 x64



External Hard Drive

Affected Products

Lenovo ideapad intel i7 laptop+windows 10 x64 + cubase 8 x64

1_disabled uac
2_installed scratchlive 2.2.0 successful!
3_installed driver_updater64.exe successful!
4_installed driver_updater32.exe no SL1 device found! nothing updated!

the SL1asio does not appear in the cubase’s asio device menu! Also doesn’t appear in audacity audio device, what’s wrong??

I have follow the guide/workaround:

Click the Windows Start menu
Click Computer and open your local C: drive
Open the Program Files (x86) folder
Open the Serato folder and then the Drivers folder
Open the ASIO folder and then open the 32 folder
Locate and copy the SL1 and 57SL folder (Ctrl C)
Back out of the 32 folder
Right click on the 64 folder and select Paste to paste the SL1 and 57SL folder
Once the folders are copied into the 64 folder and then close the Explorer window.
Click on the Windows Start menu again
Go to All Programs
Open the Serato folder
Open the ScratchLIVE folder and double click the option “Install ASIO Drivers” and follow the prompts.
After the driver successfully installs and your computer restarts, retest (you may need to disconnect and then reconnect your Rane hardware).

After the installation of scratchlive 2.2.0 (successful) I don’t have any “install asio driver.exe” in my scratchlive folder, and i don’t have any asio folder in drivers folder. The asio .dll drivers are in “drivers” root folder.

What’s the problem? How can i utilize sl1 asio driver in cubase?

{name} Rane Forum Admin

adejesus 1:39:28 - 22 March 2017

Hi Brandat!

Sorry you are having trouble with this.

Have you used a different USB cable or a different USB port on your computer? Does the SL1 appear in your Device Manager? Are you able to test the SL1 on a different computer?

You stated you were running Scratch Live 2.2.0. I would first recommend making sure you are running the latest version of Scratch Live as you are using Windows 10 this would be the best version to run. Please refer to the link provided below for the latest version of Scratch Live.


I hope this helps. Let me know if you need any further assistance.


Brandat 2:00:40 - 22 March 2017

I tried both the usb2 and usb3 but both going the same problem. In Device Manager the sl1 appears as a USB device and is connected properly without driver problem, but it don’t appears as a peripheral audio sound (i think that it’s right).
also tried it with scratchlive version 2.5, but does not solve, I installed version 2.2 because I read on the forum that solved problems with the asio 64bit.
I’ll try if the problem appears to another desktop PC intel i5, but I need it to work on this pc laptop lenovo ideapad s510p.


Brandat 5:37:14 - 25 March 2017

Update of my problem:

-I formatted and reinstalled my pc
-installed windows 10 x64, updated to today
-disabled “driver signature enforcement” function
-changed usb cable for “rane sl1 interface”
-installed “ScratchLIVE 2.5”
-fully performed the guide described in my previous post, everything fits into folders as written in the guide, all completed successfully.
-finally installed asio driver sl1 (“asio installer” in serato folder) as administrator.

installed Cubase 5 32bit successfully, here is properly seen the driver asio sl1, ok!
installed cubase 8 64bit successfully, here is not seen the driver asio sl1!! why?

the problem about asio driver sl1 and cubase 8 64bit still remains! but there is no problem for cubase 5 32bit.

why the sl1 asio driver is seen in the cubase 32bit and instead the cubase 64bit is not seen?

32/64, that’s the problem?

how do you do to see the asio driver sl1 even in cubase 64bit?

{name} Rane Forum Admin

adejesus 9:12:36 - 07 April 2017

Hi Brandat,

It seems as the unit is working just not with the version of Cubase you are using. I would recommend reach out to Steinberg the manufacture of Cubase for troubleshooting steps to try and check the full compatibility. You have everything setup correctly but i do not see a reason why the software does not recognize the unit. The only thing we can try is updating the ASIO drivers to the latest version.


I hope this helps. Let me know if you need any further assistance.


To participate in this discussion we need a few basic details from you

Publicly visible when you post in this forum discussion
Passwords must be at least 5 characters long

User Log-in

  Forgotten Password