Welcome Guest  |  Login  |  Forum Registration

El Capitan Update

Rane support for Apple OS X El Capitan (10.11.4 and higher)

 

No device driver needed 

These units are Apple Class Compliant devices, which means no 3rd party driver is necessary for use on Macintosh computers. These units are ready to go for OSX El Capitan 10.11.4 or higher.  

 

Device driver needed

These units require Rane CoreAudio device drivers to be installed to be fully compatible with El Capitan. The device drivers are compatible with Apple OS X El Capitan 10.11.4 and higher. Only versions of El Capitan 10.11.4 and higher are supported. These drivers are not compatible with older OS X versions.

Find the El Capitan CoreAudio drivers under the Downloads tab on each product page:

 

Device driver and firmware update needed

The SL2 requires installation of the Rane SL2 CoreAudio device driver and the SL2 unit's firmware updated to version 2.00 to be fully compatible with El Capitan. The device driver is compatible with Apple OS X El Capitan 10.11.4 and higher. Only versions of El Capitan 10.11.4 and higher are supported. This driver is not compatible with older OS X versions.

After installing the device driver for the SL2, open the SL2 control panel and update the firmware to version 2.00

Find the SL2 El Capitan CoreAudio driver under the Downloads tab on the SL2 product page:

 

Note:

We have received reports of a connection issue with Serato DJ on some systems for devices that require the new Rane device drivers. Please check the El Capitan Troubleshooting guide here if you are experiencing a Serato DJ connection issue with any of the devices that require the El Capitan CoreAudio device driver update.

 

SOFTWARE WITH EL CAPITAN SUPPORT